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Introduction to Photoshop: Creating a New File, Open a file, Saving a file, Main Selections, 

Picking color, Filling a selection with color, Painting with paintbrush tool, Using the magic 

wand tool and applying a filter, Color Mode, Changing Foreground and Background colors, 

Using Brushes, Using the Editing Tool, Selection Tools, Making Rectangular and Square 

Selections 

1. INTRODUCTION TO  PHOTOSHOP 

                     Photoshop is the premiere software for manipulating or creating raster based 

images. It can also be used to design an infinite number of projects. So if you have any need to 

work with digital (or scanned) photographs, or want to create backgrounds, or images for 

websites, or a poster for your lost kitten or just paint a picture- Photoshop is a great tool to have. 

                Photoshop is the industry-standard image rendering software. You can use Photoshop 

to create customized graphics, edit photographs and make flyers and images for print as well as 

for the web. 

 

http://www.thedigitalprocess.com/glossary-of-digital-photography-terms/raster/


BASIC TOOLS. 

  

              Marquee Tool : The images in Photoshop are stored pixel by pixel, with a code 

indicating the color of each. The image is just a big mosaic of dots. Therefore, before you can do 

anything in Photoshop, you first need to indicate which pixels you want to change. The selection 

tool is one way of doing this. Click on this tool to select it, then click and drag on your image to 

make a dotted selection box. Hold shift while you drag if you want a perfect square or circle. 

Any pixels within the box will be affected when you make your next move. If you click and hold 

on this tool with your mouse button down, you will see that there is also an oval selection shape, 

and a crop tool. 

                 Crop Tool: To crop your image, draw a box with the crop tool. Adjust the selection 

with the selection points, and then hit return to crop. 

                 Lasso Tool : The lasso tool lets you select freeform shapes, rather than just rectangles 

and ovals. 

                Magic Wand: Yet another way to select pixels is with the magic wand. When you 

click on an area of the image with this tool, all pixels that are the same color as the pixel you 

clicked will be selected. Double click on the tool to set the level of tolerance you would like (i.e. 

how similar in color the pixels must be to your original pixel color. A higher tolerance means a 

broader color range). 

              The Move Tool: This is a very important tool, because up until now all you have been 

able to do is select pixels, and not actually move them. The move tool not only allows you to 

move areas you have selected, but also to move entire layers without first making a selection. If 

you hold the option (or alt) key while clicking and dragging with the move tool, you can copy 

the selection. 

             Airbrush Paintbrush and Pencil tools: can be used to draw with the foreground color 

on whichever layer is selected. To change the foreground color, double-click on it in the toolbox. 

You will then see a palette of colors from which to choose. Select one and click OK. To change 

the brush size, go to Window > Show Brushes. 

             Eraser Tool: Erases anything on the selected layer. You can change the eraser size by 

going to Window > Show Brushes. 

            Line Tool: Can be used to draw straight lines. Click on the tool to select it, then click 

with the tool on the canvas area and drag to draw a line. When you release the mouse button, the 

line will end. You can change the thickness of the line or add arrowheads to it by double clicking 

on the tool to see this dialog box: 

           Text tool: Click on this tool to select it, then click in the Canvas area. You will be given a 

dialog box in which to type your text, and choose its attributes. Each new block of text goes on 

its own layer, so you can move it around with the Move Tool. Once you have placed the text, 

however, it is no longer editable. To correct mistakes, you must delete the old version (by 

deleting its layer) and replace it. 

          Eyedropper: Click with this tool on any color in the canvas to make that color the 

foreground color. (You can then paint or type with it). 

         Magnifier: Click with this tool on a part of your image you want to see closer, or drag with 

it to define the area you want to expand to the size of the window. Hold down the Option or Alt 

key to make it a "reducer" instead and zoom back out. 

        Grabber: Click with this and drag to move the entire page for better viewing. 

 



 

2. CREATE A NEW FILES IN PHOTOSHOP 

To create a new document in Photoshop, we use the New Document dialog box. There are 

several ways to get to this dialog box. 

1. When you launch Photoshop you can click on the New… button on Photoshop’s Start 

screen.or 

2. Click File > New on the Menu Bar along the top of the screen.or  

3. Use the keyboard shortcut, Cmd + N (Mac) / Ctrl + N (Win). This is a handy keyboard 

shortcut that we use over and over when working in Photoshop, so it’s worth making an 

effort to remember it. 

Any of these options open up the New Document dialog box. 

 

3.OPEN A FILE IN PHOTOSHOP 

             Choose File > Open from the menu at the top of the screen.  You can also use the                              

keyboard shortcut Cmd + O (Mac) or Ctrl + O (Win).      or  

  From the Home/Screen, click on the Open… button on the left-hand side. 

Whichever way you choose, it will open a dialog where you can browse to find your file. Click 

on the file name and click Open. 

OPEN A RECENT FILE IN PHOTOSHOP 

f you’ve already been working on some images or photos in Photoshop, you can open them 

quickly in two ways: 

1. Choose File > Open Recent, and select a file from the submenu that pops out. 

2. You can also simply click on the thumbnails of Recent files on the Home/Start screen. 

 

4.SAVE A FILE IN PHOTOSHOP 

           You can use the Save as option in the File menu to set options for saving image files, 

such as the format, and whether to include the saved file in the Elements Organizer catalog or 

to preserve layers in an image. Depending on the format you select, other options may be 

available to set. 

Use the Save command to save changes to the current file or the Save As command to save 

changes to a different file. 

Save changes to the current file  



1. Choose File > Save. 

The file remains in the current format. 

save a file with a different name, location, or format  

 

 

To save a file with Save As: 

1. With the image open in Photoshop, select File > Save As.or 

2. Press Ctrl+Shift+S (Windows) or Command+Shift+S (Mac OS). 

3. A dialog box will appear. ...  

4. Click the Format menu, then choose the desired file format. ...  

5. Click Save. 

6. Some file formats, such as JPEG and TIFF, will give you additional options when saving. 

7. A dialog box appears for choosing options when saving in some image formats. 

 

Save a file in GIF format  

1. Do one of the following: 

o Click File > Save As. 

o Press Ctrl+Shift+S (Windows) or Command+Shift+S (Mac OS). 

2. Specify a file name and location, and choose CompuServe GIF format from the format 

list. 

Your image is saved as a copy in the specified directory (unless it's already in indexed-

color mode). 

3. If you are creating an animated GIF, select the Layers As Frames option. Each layer in 

the final file will play as a single frame in the animated GIF. <TBC> 

4. Click Save. If your original image is RGB, the Indexed Color dialog box appears. 

5. If necessary, specify indexed color options in the Indexed Color dialog box and click OK. 

6. In the GIF Options dialog box, select a row order for the GIF file and click OK: 

Save a file in JPEG format  

1. Do one of the following: 

o Click File > Save As. 

o Press Ctrl+Shift+S (Windows) or Command+Shift+S (Mac OS). 

2. Choose JPEG from the format list. 

3.   Specify a file name and location, select file-saving options, and click Save. 

4. The JPEG Options dialog box opens. 



5.   If the image contains transparency, select a Matte color to simulate the appearance of 

background transparency. 

6.   Specify image compression and quality by choosing an option from the Quality menu, 

dragging the Quality slider, or entering a value between 1 and 12. 

 

  Select a format option: 

Baseline (“Standard”) 

Uses a format that is recognizable to most web browsers.  

Baseline Optimized 

Optimizes the color quality of the image and produces a slightly smaller file size. All web 

browsers do not support this option. 

Progressive 

Creates an image that is gradually displayed as it is downloaded to a web browser. Progressive 

JPEG files are slightly larger in size, require more RAM for viewing, and are not supported by 

all applications and web browsers. 

  Click OK. 

Save a file in PNG format  

1. Do one of the following: 

o Click File > Save As. 

o Press Ctrl+Shift+S (Windows) or Command+Shift+S (Mac OS). 

2. Choose PNG from the format list. 

3. Specify a file name and location, select file-saving options, and click Save. 

4. In the PNG Options dialog box, select an Interlace option and click OK. 



None 

Displays the image in a web browser only after it is completely downloaded. 

Displays low-resolution versions of the image while the full image file is downloading to 

the browser. Interlacing can make downloading time seem shorter and assures viewers 

that downloading is in progress. However, interlacing also increases file size. 

5. MAIN SELECTIONS: 

A selection is an area of a photo that you define. When you create a selection, the area is 

editable (for example, you can lighten one part of a photo without affecting the rest). You can 

make a selection with either a selection tool or a selection command. A selection border, which 

you can hide, surrounds the selection. You can change, copy, or delete pixels inside the selection 

border, but you can’t touch areas outside the selection border until you deselect the selection. 

Adobe Photoshop Elements provides selection tools for different kinds of selections. For 

example, the Elliptical Marquee tool selects circular and elliptical areas, and the Magic Wand 

tool can select an area of similar colors with one click. More complex selections can be made 

with one of the Lasso tools. You can even smooth the edges of a selection with feathering and 

anti-aliasing. 

Use selection tools  

The selection tools are located in the Tools panel, which is located, by default, on the left side of 

your screen. 

In Photoshop Elements, you must be in Expert mode to see the selection tools. 

Use the Rectangular and Elliptical Marquee tools .The Rectangular Marquee tool draws 

square or rectangular selection borders, and the Elliptical Marquee tool draws round or elliptical 



selection borders.

 

  Select the Rectangular Marquee tool (A) or the Elliptical Marquee tool (B) in the toolbox. 

  (Optional) Set marquee tool options in the Tool Options bar: 

• Specify whether to create a new selection, add to a selection, subtract from a selection, or 

select an area intersected by other selections. 

• To soften the selection border so that it blends into the area outside the selection, enter a 

Feather value. 

• To smooth the edges of your selection, select Anti-aliased (Elliptical Marquee tool only).  

• From the Mode pop-up menu, choose Normal to visually set the size and proportions of 

the selection border; Fixed Ratio to set a width-to-height ratio for the selection border; or 

Fixed Size to specify the marquee’s height and width. 

  Drag over the area you want to select. Hold down the Shift key as you drag to constrain the 

selection marquee to a square or circle. 

Click Refine Edge to make further adjustments to your selection and make it more precise. See 

how you can refine the edges of a selection. 

Use the Lasso tool  

The Lasso tool draws freehand selection borders. This tool lets you make very precise selections. 

https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#refine_edges_of_a_selection


 

  Select the Lasso tool from the toolbox. 

  (Optional) Set Lasso tool options in the Tool Options bar: 

• Specify whether to create a new selection, add to an existing selection, subtract from a 

selection, or select an area intersected by other selections. 

• To soften the selection border so that it blends into the area outside the selection, enter a 

Feather value. 

• To smooth the edges of your selection, select Anti-aliased.  

  Drag to draw a freehand selection border: 

• To add to the selection, release the mouse button; then press Shift and, when the pointer 

changes to drag. 

• To subtract from the selection, release the mouse button; then press Alt (Option in Mac 

OS) and when the pointer changes to   drag. 

• To add straight-edge segments, hold the mouse button and press Alt (Option in Mac OS); 

then release the mouse button and, when the pointer changes click where you want to 

position the end of the segment. 

  To close the selection border, release the mouse button. A straight selection segment is drawn 

from where you released the mouse button to the starting point of your selection. 

  Click Refine Edge to make further adjustments to your selection and make it more precise. 

See how you can refine the edges of a selection. 

Use the Polygonal Lasso tool  

https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#refine_edges_of_a_selection


The Polygonal Lasso tool draws straight-edged segments of a selection border. You can create as 

many segments as you need to draw a selection border. 

 

  Select the Polygonal Lasso tool from the toolbox. 

  (Optional) Set Polygonal Lasso tool options in the Tool Options bar: 

• Specify whether to create a new selection, add to an existing selection, subtract from a 

selection, or select an area intersected by other selections. 

• To soften the selection border so that it blends into the area outside the selection, enter a 

Feather value. 

• To smooth the edges of your selection, select Anti-aliased.  

  Click where you want the first straight segment to begin, and click a second time where you 

want the segment to end and the next one to begin. Continue clicking to create segments. 

If you make a mistake, press the Delete key to erase segments. You can switch from creating 

straight-edge segments to drawing freehand by pressing Alt (Option in Mac OS). 

  Close the selection border by doing one of the following: 

• Position the pointer over the starting point and click. A closed circle appears next to the 

pointer when you are over the starting point. 

• If the pointer is not over the starting point, double-click, or Ctrl-click (Command-click in 

Mac OS). A straight selection segment is drawn from your pointer to the starting point of 

your selection. 

  Click Refine Edge to make further adjustments to your selection and make it more precise. 

See how you can refine the edges of a selection. 

https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#refine_edges_of_a_selection


• Use the Magnetic Lasso tool  

• The Magnetic Lasso tool draws a selection border that automatically snaps to the edges of 

objects you drag over in the photo. This makes it easy to draw precise selection borders. 

The Magnetic Lasso tool is useful for quickly selecting objects with complex edges set 

against high-contrast backgrounds. 

Rectangular Marquee tool: Draws square or rectangular selection borders.

 

Elliptical Marquee tool: Draws round or elliptical selection borders. 

 

Lasso tool: Draws freehand selection borders, best for precision. 

 

Polygonal Lasso tool: Draws multiple straight-edged segments of a selection border. 

https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_rectangular_and_elliptical_marquee_tools
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_rectangular_and_elliptical_marquee_tools
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_lasso_tool
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_polygonal_lasso_tool


 

Magnetic Lasso tool: Draws a selection border that automatically snaps to edges when you 

drag over in the photo. 

 

Magic Wand tool: Selects pixels of similar color with one click 

 

Quick Selection tool: Quickly and automatically makes selection based on color and texture 

when you click or click-drag an area 

 

Selection Brush tool: Automatically selects or deselects the area you paint, depending on 

whether you’re in Sselection or Mask mode. 

https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_magnetic_lasso_tool
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_magic_wand_tool
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_quick_selection_tool
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_selection_brush_tool


 

Smart Brush tool: Applies color and tonal adjustments and effects to a selection. The tool 

automatically creates an adjustment layer for non-destructive editing. 

 

Refine Selection Brush tool: 

Helps you add or remove areas to and from a selection. 

 

Auto Selection tool: Automatically makes a selection when you draw a shape around an 

object 

https://helpx.adobe.com/in/photoshop-elements/using/adjusting-shadows-light.html#apply_the_smart_brush_tools
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#refine_selection_tool
https://helpx.adobe.com/in/photoshop-elements/using/making-selections.html#use_the_auto_selection_tool


 

 

6.COLOR PICKER: 

Photoshop uses the foreground color to paint, fill, and stroke selections and the background color 

to make gradient fills and fill in the erased areas of an image. The foreground and background 

colors are also used by some special effects filters. 

You can designate a new foreground or background color using the Eyedropper tool, the Color 

panel, the Swatches panel, or the Adobe Color Picker. 

The default foreground color is black, and the default background color is white 

Choose a color from the HUD color picker 

1. Select a painting tool. 

2. Press Shift + Alt + right-click (Windows) or Control + Option + Command (Mac OS). 

3. Click in the document window to display the picker. Then drag to select a color hue and 

shade. Note: After clicking in the document window, you can release the pressed keys. 

Choose colors in the toolbox  

The current foreground color appears in the upper color selection box in the toolbox; the current 

background color appears in the lower box. 

 



• To change the foreground color, click the upper color selection box in the toolbox, and 

then choose a color in the Adobe Color Picker. 

• To change the background color, click the lower color selection box in the toolbox, and 

then choose a color in the Adobe Color Picker. 

• To reverse the foreground and background colors, click the Switch Colors icon in the 

toolbox.  

• To restore the default foreground and background colors, click the Default Colors icon in 

the toolbox. 

Adobe Color Picker overview  

In the Adobe Color Picker, you choose colors using four color models: HSB, RGB, Lab, and 

CMYK. Use the Adobe Color Picker to set the foreground color, background color, and text 

color. You can also set target colors for different tools, commands, and options. 

You can configure the Adobe Color Picker to let you choose only colors that are part of the web-

safe palette or choose from specific color systems. You can also access an HDR (high dynamic 

range) picker to choose colors for use in HDR images. 

The Color field in the Adobe Color Picker displays color components in HSB color mode, RGB 

color mode, and Lab color mode. If you know the numeric value of the color you want, you can 

enter it into the text fields. You can also use the color slider and the color field to preview a color 

to choose. As you adjust the color using the color field and color slider, the numeric values are 

adjusted accordingly. The color box to the right of the color slider displays the adjusted color in 

the top section and the original color in the bottom section.

 

Although Photoshop uses the Adobe Color Picker by default, you can use a different color picker 

than the Adobe Color Picker by setting a preference. For example, you can use the built-in color 

picker of your computer’s operating system or a third-party plug-in color picker. 

Display the Color Picker  

• In the toolbox, click the foreground or background color selection box. 



• In the Color panel, click the Set Foreground Color or Set Background Color selection 

box. 

The Color Picker is also available when features let you choose a color. For example, by 

clicking the color swatch in the options bar for some tools, or the eyedroppers in some 

color adjustment dialog boxes. 

Choose a color with the Adobe Color Picker  

You can choose a color by entering color component values in HSB, RGB, and Lab text boxes, 

or by using the color slider and the color field. 

To choose a color with the color slider and color field, click in the color slider or move the color 

slider triangle to set one color component. Then move the circular marker or click in the color 

field. This sets the other two color components. 

Choose a color using the HSB model  

Using the HSB color model, the hue is specified in the color field, as an angle from 0° to 360° 

that corresponds to a location on the color wheel. Saturation and brightness are specified as 

percentages. In the color field, the hue saturation increases from left to right and the brightness 

increases from the bottom to top. 

1. In the Adobe Color Picker, select the H option and then enter a numeric value in the H 

text box or select a hue in the color slider. 

2. Adjust the saturation and brightness by clicking in the color field, moving the circular 

maker, or entering numeric values in the S and B text boxes. 

3. (Optional) Select either the S option or B option to display the color’s saturation or 

brightness in the color field for making further adjustments. 

Choose a color using the RGB model  

Choose a color by specifying its red, green, and blue components. 

1. In the Adobe Color Picker, enter numeric values in the R, G, and B text boxes. Specify 

component values from 0 to 255 (0 is no color, and 255 is the pure color). 

2. To visually select a color using the color slider and color field, click either R, G, or B and 

then adjust the slider and color field. 

The color you click appears in the color slider with 0 (none of that color) at the bottom 

and 255 (maximum amount of that color) at the top. The color field displays the range of 

the other two components, one on the horizontal axis and one on the vertical axis.  

Choose a color using the Lab model  



When choosing a color based on the Lab color model, the L value specifies the luminance of a 

color. The A value specifies how red or green a color is. The B value specifies how blue or 

yellow a color is. 

1. In the Adobe Color Picker, enter values for L (from 0 to 100), and for A and B (from 

-128 to +127). 

2. (Optional) Use the color slider or color field to adjust the color. 

Choose a color using the CMYK model  

You can choose a color by specifying each component value as a percentage of cyan, magenta, 

yellow, and black.  

1. In the Adobe Color Picker, enter percentage values for C, M, Y, and K, or use the color 

slider and color field to choose a color. 

7.FILLING A SELECTION WITH COLOR: 

Fill a selection or layer with color 

1. Choose a foreground or background color. ...  

2. Select the area you want to fill. ...  

3. Choose Edit > Fill to fill the selection or layer. ...  

4. In the Fill dialog box, choose one of the following options for Use, or select a custom 

pattern: ...  

5. Specify the blending mode and opacity for the paint. 

By Filonia LeChat 

• Share 

• Share on Facebook 

It may be second nature for you to open the Photoshop graphics software and use it to work on 

your digital photographs, but keep the program in mind for other kinds of artwork as well. 

Photoshop offers artistic tools for digital doodlers as well, with many options for coloring, 

drawing and painting right on the screen. With a couple of quick clicks, you may find that your 

computer monitor serves as a creative canvas. 

Step1 

Open Photoshop, click "File" and select "New." Type "Color" into the "Name" box and set your 

preferred drawing dimensions. For a full page of drawing, type 11 inches by 8.5 inches. Pull 

down the "Color Mode" menu and select "RGB Color." Pull down the "Background Contents" 

menu and select "White." Click the "OK" button to open the workspace. 

http://www.facebook.com/share.php?u=https://www.techwalla.com/articles/how-to-fill-color-in-photoshop&title=How%20to%20Fill%20&%20Color%20in%20Photoshop%20%7C%20Techwalla.com
http://www.facebook.com/share.php?u=https://www.techwalla.com/articles/how-to-fill-color-in-photoshop&title=How%20to%20Fill%20&%20Color%20in%20Photoshop%20%7C%20Techwalla.com


Step2 

Double click the top-left square of the "Color Picker," the two overlapping colored boxes on the 

"Tools" palette. Select a paint color from the rainbow and click the "OK" button. 

Step3 

Click the "Brush" tool, which looks like a paintbrush, on the "Tools" palette. Pull down the brush 

menu at the top of the screen, the second button from the left. Select a solid, round brush head, 

It may be second nature for you to open the Photoshop graphics software and use it to work on 

your digital photographs, but keep the program in mind for other kinds of artwork as well. 

Photoshop offers artistic tools for digital doodlers as well, with many options for coloring, 

drawing and painting right on the screen. With a couple of quick clicks, you may find that your 

computer monitor serves as a creative canvas. 

Step4 

Position your cursor on the "Color" box and draw the outline of a design, such as a flower or 

heart. 

Step5 

Click the "Paint Bucket" tool, which looks like a spilling can of paint, on the "Tools" palette. 

Click inside the outline you just drew, which fills it with the same color, making it a solid shape. 

Step6 

Switch back to the "Brush" tool, change to a new paint color and select a different, smaller brush 

head. Move the "Opacity" slider bar down to 30 percent. Color more designs on the drawing. 

Notice that now, the colors are semi-transparent, since their opacity has been turned down. 

Step7 

Move the "Opacity" slider back to 100 percent. Click the "Paint Bucket" tool again. Select a new 

color from the "Color Picker" that hasn't been used yet in the drawing. Click the white space of 

the "Color" box, which fills with color behind the drawing. 

Step8 

Click the "File" menu, select "Save As" and save the file to the computer. 

You can fill the inside of a selection, path, or layer with a color or pattern. You can also add 

color to the outline of a selection or path, called stroking. 



Fill with the Paint Bucket tool  

The Paint Bucket tool fills adjacent pixels that are similar in color value to the pixels you click.  

  Choose a foreground color. (See Choose colors in the toolbox.) 

  Select the Paint Bucket tool 

  Specify whether to fill the selection with the foreground color or with a pattern. 

  Specify a blending mode and opacity for the paint. (See Blending modes.) 

  Enter the tolerance for the fill. 

The tolerance defines how similar in color a pixel must be (to the pixel you click) to be filled. 

Values can range from 0 to 255. A low tolerance fills pixels within a range of color values very 

similar to the pixel you click. A high tolerance fills pixels within a broader range. 

  To smooth the edges of the filled selection, select Anti-aliased. 

  To fill only pixels contiguous to the one you click, select Contiguous; leave Contiguous 

unselected to fill all similar pixels in the image. 

  To fill pixels based on the merged color data from all visible layers, select All Layers. 

  Click the part of the image you want to fill. All specified pixels within the specified tolerance 

are filled with the foreground color or pattern. 

If you’re working on a layer and don’t want to fill transparent areas, make sure that the layer’s 

transparency is locked in the Layers panel. (See Lock layers.) 

Fill a selection or layer with color  

1. Choose a foreground or background color. (See Choose colors in the toolbox.) 

2. Select the area you want to fill. To fill an entire layer, select the layer in the Layers panel. 

3. Choose Edit > Fill to fill the selection or layer. Or to fill a path, select the path, and 

choose Fill Path from the Paths panel menu. 

4. In the Fill dialog box, choose one of the following options for Use, or select a custom 

pattern: 

Foreground Color, Background Color, Black, 50% Gray, or White 

Fills the selection with the specified color. 

  olor 

https://helpx.adobe.com/ie/photoshop/using/choosing-colors.html#choose_colors_in_the_toolbox
https://helpx.adobe.com/ie/photoshop/using/blending-modes.html
https://helpx.adobe.com/ie/photoshop/using/moving-stacking-locking-layers.html#lock_layers
https://helpx.adobe.com/ie/photoshop/using/choosing-colors.html#choose_colors_in_the_toolbox


Fills with a color you select from the Color Picker. 

  Specify the blending mode and opacity for the paint. (See Blending modes.) 

  If you’re working in a layer and want to fill only areas containing pixels, choose Preserve 

Transparency. 

  Click the OK button to apply the fill. 

Draw a circle or square ana fill colours. 

You can draw a circle or square using the elliptical or rectangular marquee tools, and then add a 

line (called a stroke) to the selection marquee. Stroking a selection is a quick way to add a border 

or frame around an object. You can stroke any selection you create with the selection tools.  

 In the Layers panel, click the New Layer button   to create a new layer for the circle or square.    

Isolating the circle or square on its own layer makes it easier to work with. 

  Select the Elliptical Marquee tool or the Rectangular Marquee tool  in the toolbox. 

  Drag in the document window to create the shape. Hold down the Shift key while dragging to 

constrain the shape to a circle or square. 

  Choose Edit > Stroke. 

  In the Stroke dialog box, type a value for Width, and then click the color swatch to display the 

Adobe Color Picker. 

  In the Adobe Color Picker, locate the color range you want using the triangle sliders on the 

color spectrum bar, and then click the desired color in the color field. The color you select 

appears in the top half of the color swatch. The original color remains in the bottom half. 

Click OK. 

  Set the location for the stroke in relationship to the marquee by choosing Inside, Center, or 

Outside. Adjust the other settings as desired, and click OK. Photoshop strokes the line using the 

color and stroke settings you set. 

8.PAINTING WITH PAINTBRUSH. 

The Brush tool and the Pencil tool paint the current foreground color on an image. The Brush 

tool creates soft strokes of color. The Pencil tool creates hard-edged lines. 

  Choose a foreground color. (See Choose colors in the toolbox.) 

  Select the Brush tool 

  Choose a brush from the Brush Presets panel. See Select a preset brush. 

  Set tool options for mode, opacity, and so on, in the options bar. 

  Do one or more of the following: 
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• Click and drag in the image to paint.  

• To draw a straight line, click a starting point in the image. Then hold down Shift, and 

click an ending point. 

• When using the Brush tool as an airbrush, hold down the mouse button without dragging 

to build up color.  

Paint tool options  

Set the following in the options bar. Options available vary with each tool. 

Mode 

Sets the method for blending the color you paint with the underlying existing pixels. Available 

modes change with the currently selected tool. Paint modes are similar to layer blending modes. 

See Blending modes. 

Opacity 

Sets the transparency of color you apply. As you paint over an area, the opacity does not exceed 

the set level no matter how many times you move the pointer over the area, until you release the 

mouse button. If you stroke over the area again, you apply additional color, equivalent to the set 

opacity. Opacity of 100 percent is opaque. 

Sets the rate at which color is applied as you move the pointer over an area. As you paint over an 

area, while holding down the mouse button, the amount of color builds up based on the flow rate, 

up to the opacity setting. For example, if you set the opacity to 33% and the flow to 33%, each 

time you move over an area, its color moves 33% toward the brush color. The total will not 

exceed 33% opacity unless you release the mouse button and stroke over the area again. 

Basics functions of Brushes for Photoshop 

Now go and grab the “Brush tool” from the tool bar.  
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And the first menu in option bar is “Brush preset picker”. Here we can change brush tip, this 

menu shows different types of icon are actually different types of brushes available. 

Now click on this small wheel icon. you will get here some list of different group  of preset 

brushes. These brushes are inbuilt with Photoshop. 

Paint with the Brush tool: 

1. Choose a foreground color. (See Choose colors in the toolbox.) 

2. Select the Brush tool or Pencil tool . 

3. Choose a brush from the Brush Presets panel. See Select a preset brush. 

4. Set tool options for mode, opacity, and so on, in the options bar. 

5. Do one or more of the following: 

9. USING THE MAGIC WAND TOOL AND APPLYING A FILTER 

Magic Wand: Yet another way to select pixels is with the magic wand. When you click on an 

area of the image with this tool, all pixels that are the same color as the pixel you clicked will be 

selected. Double click on the tool to set the level of tolerance you would like (i.e. how similar in 

color the pixels must be to your original pixel color. A higher tolerance means a broader color 

range). 

Magic Wand tool: Selects pixels of similar color with one click 
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  Go to File > Open and navigate to an image. In this example, we will use an image of an 

eagle with a blue sky background. 

  Go to File > Save As and rename the file. This is a practical way to make sure you keep an 

original copy of the image. 

.Go to the Toolbar, click and hold on the Quick Selection Tool, and select the Magic Wand Tool. 

 

  Click and release on the area you want to select. In this case, we have clicked on the blue sky 

above the eagle. Most of the sky will be selected, but there may be an area that isn't if there is a 

gradient in color there. 

  Hold down the Shift key and then click on any area that was left unselected. Notice that while 

the Shift key is held down, a small plus sign appears next to the cursor indicating that you will be 

adding to the selection. The Alt (PC)/Option (Mac) key would produce a minus sign in the 

cursor, allowing you to subtract from a selection. 

  Go to the Select menu and choose Inverse to flip-flop the selected area, so now the object in 

your image (in this case the eagle) is selected. Inversing is a useful technique for isolating an 

image area that is against a solid, uniform background color. 

  Zoom in on the object and then go to the Filter > Sharpen menu and select Unsharp Mask. 

.In the Unsharp Mask dialog box, enter 200 in the Amount field, and 20 in the Threshold field. 

This will increase the detail in the image by accentuating the highlight and shadow. You can 

adjust these numbers to suit your image. Toggle the Preview on and off to see the difference. 

Click OK. 

Best Uses for the Magic Wand 

With a little effort and some time spent learning how to use its features, the Magic Wand is 

useful with any image. However, when you are first starting with Photoshop, you may want to 



stick with images that have clear contrasts and clean lines. If you talk to many Photoshop users, 

you will find that the Magic Wand feature is commonly used to select solid backgrounds. 

Features for the Magic Wand 

       The Magic Wand is similar to Photoshop’s other selection tools in that it allows you to 

easily add and subtract from your chosen areas without having to repeatedly go through the 

process from scratch. It also includes the option for feathering, which creates a more rounded 

selection, and anti-aliasing, which evens out those rough lines. 

10.COLOR MODE OR IMAGE MODE 

The color mode, or image mode, determines how the components of a color are combined, based 

on the number of color channels in the color model. Color modes include grayscale, RGB, and 

CMYK, among others. Photoshop Elements supports bitmap, grayscale, indexed, and RGB color 

modes. 

 

RGB mode (millions of colors); 2: Index Color mode (256 colors); 3: Grayscale mode (2 

colors); 4: Bitmap mode (2 colors) 

Different color modes: 

1. RGB mode (millions of colors) 

2. CMYK mode (four-printed colors) 

3. Index mode (256 colors) 

4. Grayscale mode (256 grays) 

5. Bitmap mode (2 colors) 

The color mode or image mode determines how colors combine based on the number of channels 

in a color model. Different color modes result in different levels of color detail and file size. For 

instance, use CMYK color mode for images in a full-color print brochure, and use RGB color 

mode for images in web or e-mail to reduce file size while maintaining color integrity. 



RGB Color mode  

Photoshop RGB Color mode uses the RGB model, assigning an intensity value to each pixel. In 

8-bits-per-channel images, the intensity values range from 0 (black) to 255 (white) for each of 

the RGB (red, green, blue) components in a color image. For example, a bright red color has an 

R value of 246, a G value of 20, and a B value of 50. When the values of all three components 

are equal, the result is a shade of neutral gray. When the values of all components are 255, the 

result is pure white; when the values are 0, pure black. 

RGB images use three colors, or channels, to reproduce colors on screen. In 8-bits-per-channel 

images, the three channels translate to 24 (8 bits x 3 channels) bits of color information per pixel. 

With 24-bit images, the three channels can reproduce up to 16.7 million colors per pixel. With 

48-bit (16-bits-per-channel) and 96-bit (32-bits-per-channel) images, even more colors can be 

reproduced per pixel. In addition to being the default mode for new Photoshop images, the RGB 

model is used by computer monitors to display colors. This means that when working in color 

modes other than RGB, such as CMYK, Photoshop converts the CMYK image to RGB for 

display on screen. 

Although RGB is a standard color model, the exact range of colors represented can vary, 

depending on the application or display device. The RGB Color mode in Photoshop varies 

according to the working space setting that you specify in the Color Settings dialog box. 

CMYK Color mode  

In the CMYK mode, each pixel is assigned a percentage value for each of the process inks. The 

lightest (highlight) colors are assigned small percentages of process ink colors; the darker 

(shadow) colors higher percentages. For example, a bright red might contain 2% cyan, 93% 

magenta, 90% yellow, and 0% black. In CMYK images, pure white is generated when all four 

components have values of 0%. 

Use the CMYK mode when preparing an image to be printed using process colors. Converting an 

RGB image into CMYK creates a color separation. If you start with an RGB image, it’s best to 

edit first in RGB and then convert to CMYK at the end of your editing process. In RGB mode, 

you can use the Proof Setup commands to simulate the effects of a CMYK conversion without 

changing the actual image data. You can also use CMYK mode to work directly with CMYK 

images scanned or imported from high-end systems. 

Although CMYK is a standard color model, the exact range of colors represented can vary, 

depending on the press and printing conditions. The CMYK Color mode in Photoshop varies 

according to the working space setting that you specify in the Color Settings dialog box. 

Lab Color mode  

The CIE L*a*b* color model (Lab) is based on the human perception of color. The numeric 

values in Lab describe all the colors that a person with normal vision sees. Because Lab 

describes how a color looks rather than how much of a particular colorant is needed for a device 



(such as a monitor, desktop printer, or digital camera) to produce colors, Lab is considered to be 

a device-independent color model. Color management systems use Lab as a color reference to 

predictably transform a color from one color space to another color space. 

The Lab Color mode has a lightness component (L) that can range from 0 to 100. In the Adobe 

Color Picker and Color panel, the a component (green-red axis) and the b component (blue-

yellow axis) can range from +127 to –128.  

Lab images can be saved in Photoshop, Photoshop EPS, Large Document Format (PSB), 

Photoshop PDF, Photoshop Raw, TIFF, Photoshop DCS 1.0, or Photoshop DCS 2.0 formats. 

You can save 48-bit (16-bits-per-channel) Lab images in Photoshop, Large Document Format 

(PSB), Photoshop PDF, Photoshop Raw, or TIFF formats. 

Grayscale mode  

Grayscale mode uses different shades of gray in an image. In 8-bit images, there can be up to 256 

shades of gray. Every pixel of a grayscale image has a brightness value ranging from 0 (black) to 

255 (white). In 16-and 32-bit images, the number of shades in an image is much greater than in 

8-bit images. 

Grayscale values can also be measured as percentages of black ink coverage (0% is equal to 

white, 100% to black). 

Grayscale mode uses the range defined by the working space setting that you specify in the Color 

Settings dialog box. 

Bitmap mode  

Bitmap mode uses one of two color values (black or white) to represent the pixels in an image. 

Images in Bitmap mode are called bitmapped 1-bit images because they have a bit depth of 1. 

Duotone mode  

Duotone mode creates monotone, duotone (two-color), tritone (three-color), and quadtone (four-

color) grayscale images using one to four custom inks. 

Indexed Color mode  

Indexed Color mode produces 8-bit image files with up to 256 colors. When converting to 

indexed color, Photoshop builds a color lookup table (CLUT), which stores and indexes the 

colors in the image. If a color in the original image does not appear in the table, the program 

chooses the closest one or uses dithering to simulate the color using available colors.  

Although its palette of colors is limited, indexed color can reduce file size yet maintain the visual 

quality needed for multimedia presentations, web pages, and the like. Limited editing is available 

in this mode. For extensive editing, you should convert temporarily to RGB mode. Indexed color 



files can be saved in Photoshop, BMP, DICOM (Digital Imaging and Communications in 

Medicine), GIF, Photoshop EPS, Large Document Format (PSB), PCX, Photoshop PDF, 

Photoshop Raw, Photoshop 2.0, PICT, PNG, Targa®, or TIFF formats. 

Multichannel mode  

Multichannel mode images contain 256 levels of gray in each channel and are useful for 

specialized printing. Multichannel mode images can be saved in Photoshop, Large Document 

Format (PSB), Photoshop 2.0, Photoshop Raw, or Photoshop DCS 2.0 formats. 

These guidelines apply when converting images to Multichannel mode: 

• Layers are unsupported and therefore flattened.  

• Color channels in the original image become spot color channels in the converted image.  

• Converting a CMYK image to Multichannel mode creates cyan, magenta, yellow, and 

black spot channels. 

• Converting an RGB image to Multichannel mode creates cyan, magenta, and yellow spot 

channels. 

• Deleting a channel from an RGB, CMYK, or Lab image automatically converts the 

image to Multichannel mode, flattening layers. 

• To export a multichannel image, save it in Photoshop DCS 2.0 format 

11. CHANGING FOREGROUND AND BACKGROUND COLORS 

             Select the Eyedropper tool on the toolbox, and then click anywhere in the active 

document to change the foreground color. Hold down the Alt (Win) or Option (Mac) key, and 

then click to change the background color. Click on a color swatch in the Swatches panel to 

change the foreground color. 

Steps 

1.Open your Adobe Photoshop program. 

2.Locate “Set Foreground Color” tool. It's located at the bottom of the toolbox on your left 

side and it looks like two squares stacking on top of one another. 

 



Click the top square. This square is on the first top of the other square. A Color Picker box for 

foreground color opens. 

 

Select a color hue on the sliding scale. It is located at the center of the Color Picker box. You 

can either drag up and down or click on one hue for your foreground color. As you drag the 

sliding scale up and down, the color in the color field to your left changes along with its value 

and saturation variants. 

 

Choose a color in the color field to your left. The color field is located at the left side of the 

Color Picker box; it looks like the biggest square displaying different shades of colors. By 

clicking on any color, the display on the small square to the right side of the hue sliding scale 

will change. This square is separated into two horizontal squares indicating your chosen current 

and new colors. 

 



Click “OK” button. It is on the top right hand side of the Color Picker box. When you are 

satisfied with the foreground color of your choice, click the button “OK.”  

The new foreground color displays. The “Set Foreground Color” square at the bottom of the 

toolbox displays your new foreground color.  

 

The editing tools are found below the selecting tools on the tools panel. Naturally, they all have 

different functions related to editing an image. You can do simple procedures like draw or erase, 

or perform more complex tasks like dodging and burning -- manipulating the exposure of 

selected areas -- that will make for studio quality prints and creative visuals. 

 

 

• Spot Healing Brush Tool: Corrects blemishes in the image like dust specs and blends 

the final image 

• Brush Tool: Paints on the image, allows you to select size of brush area as well as color 

• Clone Stamp Tool: Copy pixels from one part of the image and recreate elsewhere 

• History Brush Tool: Kind of "unpaints" the edits you made; this brush will revert the 

selected parts of the image you drew on back to the original form 

• Eraser Tool: Erases pixels from the image, exposing the layer below the image you are 

working on, or the blank sheet if no layer is there 

• Gradient Tool: Creates a blending of foreground and background colors in the image 

• Blur Tool: Makes parts of the image blurry; useful when creating a selective focus 

• Dodge Tool: A useful tool for brightening dark areas of an image; the Burn Tool (nested 

within the Dodge Tool) darkens bright areas of an image 

As with the Selection Tools, there are other tools with similar functions nested within each of the 

default Editing Tools on display. Remember, click and hold over any of the tools to see the 

variant options. 

• Spot Healing Brush: Healing Brush, Patch, Content-Aware Move, Red Eye 

• Brush: Pencil, Color Replacement, Mixer Brush 

• Clone Stamp: Pattern Stamp 

• History Brush: Art History Brush 



• Eraser: Background Eraser, Magic Eraser 

• Gradient: Paint Buckets, 3D Material Drop 

• Blur: Sharpen, Smudge 

• Dodge: Burn, Sponge 

Dodging and Burning  

Dodging part of an image means that you are brightening up that part, whereas burning it means 

you are making it darker. In the image below, the area of grass above the dog has been dodged, 

and the area below him has been burned while the area by the hose has been left alone. 

These tools can be especially useful if you are cropping part of an image out and layering 

it on another image, merging the two, and you want to get rid of the "halo effect" -- the 

bright contrast around the perimeter of the cropped image -- and make the final result 

look pure. 

12.USING BRUSH TOOL: 

The Brush tool and the Pencil tool paint the current foreground color on an image. The Brush 

tool creates soft strokes of color. The Pencil tool creates hard-edged lines. 

  Choose a foreground color. (See Choose colors in the toolbox.) 

  Select the Brush tool 

  Choose a brush from the Brush Presets panel. See Select a preset brush. 

  Set tool options for mode, opacity, and so on, in the options bar. 

  Do one or more of the following: 

• Click and drag in the image to paint.  

• To draw a straight line, click a starting point in the image. Then hold down Shift, and 

click an ending point. 

• When using the Brush tool as an airbrush, hold down the mouse button without dragging 

to build up color.  

Paint tool options  

Set the following in the options bar. Options available vary with each tool. 

Mode 
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Sets the method for blending the color you paint with the underlying existing pixels. Available 

modes change with the currently selected tool. Paint modes are similar to layer blending modes. 

See Blending modes. 

Opacity 

Sets the transparency of color you apply. As you paint over an area, the opacity does not exceed 

the set level no matter how many times you move the pointer over the area, until you release the 

mouse button. If you stroke over the area again, you apply additional color, equivalent to the set 

opacity. Opacity of 100 percent is opaque. 

Sets the rate at which color is applied as you move the pointer over an area. As you paint over an 

area, while holding down the mouse button, the amount of color builds up based on the flow rate, 

up to the opacity setting. For example, if you set the opacity to 33% and the flow to 33%, each 

time you move over an area, its color moves 33% toward the brush color. The total will not 

exceed 33% opacity unless you release the mouse button and stroke over the area again. 

Basics functions of Brushes for Photoshop 

Now go and grab the “Brush tool” from the tool bar.  

 

And the first menu in option bar is “Brush preset picker”. Here we can change brush tip, this 

menu shows different types of icon are actually different types of brushes available. 

Now click on this small wheel icon. you will get here some list of different group  of preset 

brushes. These brushes are inbuilt with Photoshop. 

Paint with the Brush tool: 

6. Choose a foreground color. (See Choose colors in the toolbox.) 

7. Select the Brush tool or Pencil tool . 

8. Choose a brush from the Brush Presets panel. See Select a preset brush. 
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9. Set tool options for mode, opacity, and so on, in the options bar. 

10. Do one or more of the following: 

 

13.SELECTION TOOLS: 

The selection tools are located in the Tools panel, which is located, by default, on the left side of 

your screen. 

In Photoshop Elements, you must be in Expert mode to see the selection tools. 

Use the Rectangular and Elliptical Marquee tools .The Rectangular Marquee tool draws 

square or rectangular selection borders, and the Elliptical Marquee tool draws round or elliptical 

selection borders. 

 

  Select the Rectangular Marquee tool (A) or the Elliptical Marquee tool (B) in the toolbox. 

  (Optional) Set marquee tool options in the Tool Options bar: 

• Specify whether to create a new selection, add to a selection, subtract from a selection, or 

select an area intersected by other selections. 

• To soften the selection border so that it blends into the area outside the selection, enter a 

Feather value. 

• To smooth the edges of your selection, select Anti-aliased (Elliptical Marquee tool only).  

• From the Mode pop-up menu, choose Normal to visually set the size and proportions of 

the selection border; Fixed Ratio to set a width-to-height ratio for the selection border; or 

Fixed Size to specify the marquee’s height and width. 

  Drag over the area you want to select. Hold down the Shift key as you drag to constrain the 

selection marquee to a square or circle. 

Click Refine Edge to make further adjustments to your selection and make it more precise. See 

how you can refine the edges of a selection. 

Use the Lasso tool  
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The Lasso tool draws freehand selection borders. This tool lets you make very precise selections. 

 

  Select the Lasso tool from the toolbox. 

  (Optional) Set Lasso tool options in the Tool Options bar: 

• Specify whether to create a new selection, add to an existing selection, subtract from a 

selection, or select an area intersected by other selections. 

• To soften the selection border so that it blends into the area outside the selection, enter a 

Feather value. 

• To smooth the edges of your selection, select Anti-aliased.  

  Drag to draw a freehand selection border: 

• To add to the selection, release the mouse button; then press Shift and, when the pointer 

changes to drag. 

• To subtract from the selection, release the mouse button; then press Alt (Option in Mac 

OS) and when the pointer changes to   drag. 

• To add straight-edge segments, hold the mouse button and press Alt (Option in Mac OS); 

then release the mouse button and, when the pointer changes click where you want to 

position the end of the segment. 

  To close the selection border, release the mouse button. A straight selection segment is drawn 

from where you released the mouse button to the starting point of your selection. 

  Click Refine Edge to make further adjustments to your selection and make it more precise. 

See how you can refine the edges of a selection. 
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Use the Polygonal Lasso tool  

The Polygonal Lasso tool draws straight-edged segments of a selection border. You can create as 

many segments as you need to draw a selection border. 

 

  Select the Polygonal Lasso tool from the toolbox. 

  (Optional) Set Polygonal Lasso tool options in the Tool Options bar: 

• Specify whether to create a new selection, add to an existing selection, subtract from a 

selection, or select an area intersected by other selections. 

• To soften the selection border so that it blends into the area outside the selection, enter a 

Feather value. 

• To smooth the edges of your selection, select Anti-aliased.  

  Click where you want the first straight segment to begin, and click a second time where you 

want the segment to end and the next one to begin. Continue clicking to create segments. 

If you make a mistake, press the Delete key to erase segments. You can switch from creating 

straight-edge segments to drawing freehand by pressing Alt (Option in Mac OS). 

  Close the selection border by doing one of the following: 

• Position the pointer over the starting point and click. A closed circle appears next to the 

pointer when you are over the starting point. 

• If the pointer is not over the starting point, double-click, or Ctrl-click (Command-click in 

Mac OS). A straight selection segment is drawn from your pointer to the starting point of 

your selection. 



  Click Refine Edge to make further adjustments to your selection and make it more precise. 

See how you can refine the edges of a selection. 

• Use the Magnetic Lasso tool  

• The Magnetic Lasso tool draws a selection border that automatically snaps to the edges of 

objects you drag over in the photo. This makes it easy to draw precise selection borders. 

The Magnetic Lasso tool is useful for quickly selecting objects with complex edges set 

against high-contrast backgrounds. 

Rectangular Marquee tool: Draws square or rectangular selection borders.

 

Elliptical Marquee tool: Draws round or elliptical selection borders. 

 

Lasso tool: Draws freehand selection borders, best for precision. 

 

Polygonal Lasso tool: Draws multiple straight-edged segments of a selection border. 
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Magnetic Lasso tool: Draws a selection border that automatically snaps to edges when you 

drag over in the photo. 

 

Magic Wand tool: Selects pixels of similar color with one click 

 

Quick Selection tool: Quickly and automatically makes selection based on color and texture 

when you click or click-drag an area 

 

Selection Brush tool: Automatically selects or deselects the area you paint, depending on 

whether you’re in Sselection or Mask mode. 
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Smart Brush tool: Applies color and tonal adjustments and effects to a selection. The tool 

automatically creates an adjustment layer for non-destructive editing. 

 

Refine Selection Brush tool: 

Helps you add or remove areas to and from a selection. 

 

Auto Selection tool: Automatically makes a selection when you draw a shape around an 

object 
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14. RECTANGULAR AND SQUARE SELECTIONS 

              The Rectangular Marquee Tool sitting at the very top of the Tools panel in 

Photoshop. It's the tool with the icon that looks like the outline of a square. Click on it to 

select it: 

 

The Rectangular Marquee Tool is located at the top of the Tools panel. 

 

Drawing Rectangular Selections 

Using the Rectangular Marquee Tool in its most basic form is easy. You simply click with 

your mouse at the point where you want to begin the selection, which will usually be in the 

top left corner of the object or area you need to select, then continue holding your mouse 

button down as you drag towards the bottom right corner of the object or area. When you 

release your mouse button, the selection is complete! 



 

See that large red block in the top row? Let's say I wanted to change its color, a very simple thing 

to do. Now, if this was Star Trek, I could simply say "Computer, select red block, top row", 

followed by "Change color to purple", or whatever color we wanted. Unfortunately, reality hasn't 

quite caught up to science fiction just yet, but that doesn't mean life in this day and age is 

unbearably difficult. Far from it! Photoshop may not be able to identify the wooden block, since 

all it sees are pixels, but not only can you and I see it, we can see that it's very clearly in the 

shape of a rectangle, which means that the task of selecting it is perfectly suited for the 

Rectangular Marquee Tool. 

First, I'll select the Rectangular Marquee Tool from the Tools panel as we saw a moment ago. 

You can also select tools using their keyboard shortcuts. Pressing the letter M on your keyboard 

will instantly select the Rectangular Marquee Tool. Then, to begin the selection, I'll click in the 

top left corner of the block. While still holding down my mouse button, I'll drag towards the 

bottom right corner of the block: 



 

If you find that you didn't begin your selection in exactly the right spot, there's no need to start 

over. Just hold down your spacebar, then drag your mouse to move the selection where you 

need it. When you're done, release your spacebar and continue dragging out the selection. 

To complete the selection, all I need to do is release my mouse button. The wooden block is now 

selected (or at least, the pixels that make up what we see as the block are selected), and a 

selection outline appears around the block in the document window. Any edits I make at this 

point will affect that specific block and no others: 

To change the color of the block, we'll use Photoshop's Hue/Saturation image 

adjustment. To select it, I'll go up to the Image menu at the top of the screen where I'll 

choose Adjustments and then Hue/Saturation: 



 

The Hue/Saturation image adjustment is great for changing the color of objects in an image. 

This brings up the Hue/Saturation dialog box. I think I'll change the block's color to orange. I 

know I said purple earlier, but now that I've had a few more minutes to think about it, a nice 

bright orange would probably be a better choice. Changing the color is as easy as dragging the 

Hue slider left or right until you find the color you want. I'm going to drag mine towards the 

right to a value of 28 to select orange. Then, to bump up the color saturation a bit, I'll drag the 

Saturation slider towards the right to a value of around +25: 

 

change an object's color by dragging the Hue slider. Increase or decrease color saturation with 

the Saturation slider. 



When I'm happy with the new color, I'll click OK to exit out of the dialog box. I don't need my 

selection anymore, so to remove it, I'll go up to the Select menu at the top of the screen and 

choose Deselect: 

 Remove selections by choosing Deselect 

from under the Select menu. 

A faster way to remove a selection is with the keyboard shortcut, Ctrl+D (Win) / Command+D 

(Mac), but either way will work. With the selection outline now gone, we can see that only the 

area that was inside the rectangular selection outline was affected by the Hue/Saturation 

adjustment. The formerly red block is now an orange block, while the rest of the photo remains 

unchanged: 

 

Only the area inside the rectangular selection was affected by the Hue/Saturation adjustment. 



Drawing Square Selections 

So far, we've seen how easy it is to select a rectangular-shaped object or area in a photo with the 

Rectangular Marquee Tool, but what if you need to select something that's perfectly square? Is 

there a way to force the selection outline into a square? Not only is there a way to do it, there's 

actually two ways to do it, although one of them is much faster than the other. 

Here's a photo I have open in Photoshop of some rather grungy looking tiles: 

 

Let's say I want to select the tile in the center so I can use it as an interesting background or 

texture for an effect. Since the tile is obviously square, we'll want to constrain our selection to a 

square. First, we'll look at the long way to go about it.  

Any time the Rectangular Marquee Tool is selected, the Options Bar at the top of the screen will 

display options specifically for this tool. One of the options is called Style, and by default, it's set 

to Normal, which means we're free to drag out any size selection we need with any dimensions. 

To force the selection into a square, first change the Style option to Fixed Ratio, then enter a 

value of 1 for both the Width and Height options (1 is the default value for the Width and 

Height so you may not need to change it):  

 



Change the Style option to Fixed Ratio, then set both the Width and Height to 1. 

This forces the selection into a width to height aspect ratio of 1:1, which means the width and 

height of our selection will always be equal to each other, which means we can now easily draw 

out a perfect square. I'll click with my mouse in the top left corner of the tile to begin my 

selection, just as I did previously, and with my mouse button still down, I'll drag towards the 

bottom right corner of the tile. This time, thanks to the options I set in the Options Bar, my 

selection outline is constrained to a square: 

 

Once again, there's no need to start over if you didn't begin your selection in the right spot. Just 

hold down your spacebar, drag the selection to its new location, then release the spacebar and 

continue dragging out the rest of the selection. 

To complete the selection, I'll release my mouse button, and we can see in the document window 

that the square tile in the center is now selected, ready for whatever I decide to do with it:

 



The only problem with using this method to force the selection into a square is that the 

options in the Options Bar are "sticky", meaning they don't automatically switch back to 

their default settings the next time you go to use the tool. I can't even begin to tell you 

how many times I've tried to drag out a rectangular selection only to have the selection 

constrained to a square or some other aspect ratio because I forgot to change the Style 

option back to Normal. So, before we go any further, let's change it back to Normal right 

now: 

 

 

A much better way to constrain a selection to a square with the Rectangular Marquee Tool is 

with a simple keyboard shortcut. Click on the starting point and begin dragging out a rectangular 

selection as you normally would, then hold down your Shift key as you continue to drag. As 

soon as you press the Shift key, you'll see the selection outline jump to a perfect square. Keep 

holding the Shift key down until you're finished drawing the selection. Release your mouse 

button to complete the selection, then release the Shift key. 

The order you do things here is important. If you release your Shift key before releasing your 

mouse button to complete the selection, your selection outline will jump back into a rectangular 

shape and you'll have to press and hold the Shift key again to switch back to the square. Also, if 

you hold the Shift key down before clicking to begin your selection, you'll enter the Add to 

Selection mode, which isn't something we need to get into here but it could give you unexpected 

results if you already have one selection active and try to start a new one. So remember, to 

constrain the selection to a square with the keyboard shortcut, first click to set a starting point 

and begin dragging, then hold down the Shift key. Release your mouse button to complete the 

selection, then release the Shift key. 

Next, we'll learn how to drag a rectangular or square selection out from its center! 

Drawing Selections From The Center 

Up to this point, we've been starting all of our rectangular or square selections from the top left 

corner of whatever it was that we were selecting, and in most cases that works just fine. But 

there's no rule that says you must always start in the top left corner. In fact, Photoshop gives us a 

simple keyboard shortcut that allows us to drag selections out from their center rather than from 

a corner.  

https://www.photoshopessentials.com/photo-editing/basic-selections/
https://www.photoshopessentials.com/photo-editing/basic-selections/


Click on your starting point in the center of the area you need to select with the Rectangular 

Marquee Tool and begin dragging out your selection, then hold down your Alt (Win) / Option 

(Mac) key and continue dragging. As soon as you add the Alt / Option key, your selection 

outline will begin extending out in all directions from the point you initially clicked on. Continue 

dragging the selection out from its center, release your mouse button to complete the selection, 

then release your Alt / Option key: 

 

Once again, the order you do things here is important. If you release your Alt / Option key before 

releasing your mouse button to complete the selection, the selection outline will jump back to its 

default behavior of extending out from the corner. You'll need to press and hold the Alt / Option 

key again to switch it back to the center. Also, if you press and hold Alt / Option before clicking 

to set a start point, you'll enter the Subtract from Selection mode which we won't get into here 

but can cause unexpected results if you already have one selection active and try to start a new 

one. The correct order for drawing rectangular selections from the center is to click to set a 

starting point and begin dragging, then hold down Alt / Option and continue dragging. Release 

your mouse button to complete the selection, then release your Alt / Option key. 

You can drag out a square selection from its center as well. Simply add the Shift key to the 

keyboard shortcut. Click in the center of the square object or area you need to select and begin 

dragging out the selection, then hold down Shift+Alt (Win) / Shift+Option (Mac) which will 

snap the selection outline into a perfect square and force the selection to extend out in all 

directions from the point you clicked on. When you're done, release your mouse button, then 

release the Shift and Alt / Option keys. 

Quickly Remove A Selection 

When you're done with a selection and no longer need it, you can deselect it by going up to the 

Select menu at the top of the screen and choosing Deselect as we saw earlier, or you can use the 

keyboard shortcut Ctrl+D (Win) / Command+D (Mac). Or, for an even faster way to deselect a 

rectangular or square selection, simply click anywhere inside the document window while you 

still have the Rectangular Marquee Tool active. 

https://www.photoshopessentials.com/photo-editing/basic-selections/

